Waves Warning

New Mac OS software upgrade not supported      16/03/07

Waves Warning


Apple’s lastest upgrade (10.4.9) to their operating system has been made available this week but Waves are warning users of their plug-ins not to install it until further notice.They say that Mac OS 10.4.9 is not supported and causes Waves plug-ins to malfunction.
More information:


Waves Doubler - Double Tracking Effects Plug-In (Native/SoundGrid, Download)
$99.00


Waves SSL 4000 Collection - Vintage Style Dynamics/EQ Plug-Ins Bundle (Native/SoundGrid, Download)
$249.00


More Videos

Preview: Softube Modular Eurorack Emulation Plugin 

Got any questions?


Sonic LAB: KMI K-Mix Mixer Review 

Digital mixer, audio interface and MIDI controller


BPM2016: Roland System 8 More Details 

Splits, layers, dual synth engines, step sequencer, CV/Gate


Roland DJ808 - We Ask Questions 

Product Manager Nick provides answers