Sonic State Studio / Midi/Sync Interfaces / MOTU Midi Express XT

Average rating: 7.1/10 out of 10

page 2 of 9:   1   2   3   4   5   6   7   8   9    
DeadZone writes:
Still working like a tank. Great! Rating is raising.

Rating: 9 out of 10 posted Wednesday, 12-Jan-05 at 2:36
Andy Morrison a part-timer user from Scotland writes:
Tried for weeks, with no success, to get my PC's (both XP and Win98) to communicate correctly with the Midi Express XP USB.

Purchased latest ROM upgrade which solved the problem. System very stable now.

Rating: 8 out of 10 posted Tuesday, 11-Jan-05 at 4:14
DeadZone writes:
I have fighted with this parallel interface so much... It has worked with Windows 98 like a tank. Few years ago I used it with Windows 2000 and it worked fine. Never got work with Windows XP, always gave me just two ports: Flyer A and Flyer B. Btw I have owned Flyer too and it worked very well. Anyway, that pissed me so much I never installed XP since now! I went to MOTU homepage and downloaded latest drivers (2.5x) and now there were even info how to install the drivers (also they mentioned that drivers have been tested with Win2k/XP). I did everything like they said and guess what? It worked!! I was amazed... I was going kick it out of studio but then miracle happened. I just wish it will keep working...

Rating: 8 out of 10 posted Thursday, 09-Dec-04 at 7:32
Chuck a part-timer user from USA writes:
I got a USB MIDIExpress XT second-hand for my Mac OS9 rig and it had worked flawlessly...

Then I upgraded to OS X and the thing is practically useless. It misses presses and releases so much I can't really use it. I'm wearing out the PANIC button on the thing!

I fiddled as much as I could with reinstalling the drivers, messing with the patchbay settings (there are no signs of a bad MIDI loop) and it really looks like an issue at the driver/software end.

Anyone gone through this?

Rating: 2 out of 10 posted Monday, 01-Nov-04 at 9:32
writes:
Posted by spaceCAKE: "...it installs under sound, video and game controllers by default.."

Oh no it doesn't; it never did on my computers (hello, XP and 2000 on different computers).

Anybody else with the driver installing under SYSTEM DEVICES?

posted Sunday, 12-Sep-04 at 17:4
page 2 of 9:   1   2   3   4   5   6   7   8   9    

Add your review
NEW SYSTEM - to keep the user reviews focussed, we are now approving all submissions before they appear.
We will endeavour to process your comments within 24hrs

Do not post items for sale or wanted here (they will be removed)
Use the Sonic Free Ads
Name
Email
Mail me Sonic State News
From:
(Country)
[ Professional Part TimeHobby-ist ] User
Nature of comments:
comment question
Whaddaya think: (blank lines are converted to paragraph breaks)
No HTML please.
Score 1=low 10=hi