Sonic State Studio / Audio Cards/Hardware / FOCUSRITE Saffire Pro

Average rating: 5.6/10 out of 10

page 1 of 4:   1   2   3   4    
Paulbug a Professional user from U.K writes:
Wow i cant believe how much negative feedback there is on the saffire 26 i/o. I have to admit I’ve had my problems with it too, but let’s set s few things straight....

As with any new soundcard I have ever added to a new/existing system there are always hickups. The main problem for saffire pro 26 i/o windows xp users (like myself) is that the card will not allow the firmware to be updated to the latest version if you use windows xp service pack 3. I performed a fresh windows installation on my quad core, updated to service pack 2 and everything worked as it should. I was in touch with focusrite for a while and they were really helpful about this problem, i actually provided a schematic of my studio setup and they gave me the correct configuration I needed to get things right. I can post this if anyone needs it?

I did/do experience the clicking and general plethora of problems with regards to the digital sync, however this can be due to digital sw/hardware clock sources and if you use multiple sources this can be tricky to setup correctly. E.g. i use behringer pro 8 digital ultragain to convert adat in port 1 to analogue and a dedicated pc with a korg oasys pci soundcard for the adat in port 2, sp/diff is connected to my old school Yamaha o1v (in + out) (digital sync not reliable). I currently use the ultragain pro 8 as my clock source which works fine for just this interface and the sp/diff, when I add the oasys to the equation (adat running out the oasys and in to the saffire) this is when clicking occurs, focusrite told me to get another adat lead and to make sure both the adat in and out are connected to the saffire and oasys respectively. I don’t know if this problem can ever be cured due to the lack of support for the old oasys pci card, but what I do know is that the oasys runs fine with both adat leads connected, I’m yet to get another adat lead, I’ll be sure to report back when I do!

I thought it might be worth mentioning that I cant comment on mac users as I’m a pc only kinda guy. I have to admit if the new lead doesn’t sort the problem out I’m going to be onto focusrite for a replacement unit. It’s a real shame as my previous soundcard the 1st edition portable saffire (white) worked perfect after I got the firmware updated (however the firmware updates were sometimes problematic). I will stick with focusrite as I honestly believe they make the best quality cards on the market, no other soundcard has that polished sound you get with focusrite hardware unless you spend thousands. It’s all about the sound people:)

To quickly sum up, it can be many factors contributing to the clicks and pops in a complex digital audio setup. I would suggest plugging in 1 adat device at a time to find out where the real problem lies.

Rating: 8 out of 10 posted Tuesday, 02-Dec-08 at 8:42
Luvleggs a Professional user from US writes:
I've had mine for the last 6 months and I have yet to have a problem. I did however set my system up as DAW only, it doesn't surf the net or do anything other than run Sonar and I had all the tweaks done that aren't needed on a dedicated unit, like turning off windows sounds, transition effects, monitor refresh rates, screen savers etc. If you treat the machine right it will treat you right.

Rating: 9 out of 10 posted Tuesday, 30-Sep-08 at 15:49
Craig from Canada writes:
bought the saffire 26 i/o.. 2 bad/noisy preamps. Ive owned plenty of interfaces but this one gave me a bad feeling.. im going with the MOTU

posted Thursday, 22-May-08 at 19:39
Paul a Professional user from England writes:
Well. What can i say... I think its good but im getting those popping noises and clicking and that. ive turned the sound off on windows apps n that which improved it. but what really has pissed me off is the lack of support and the update to 2.4 just fucks everything up. so. its alright if you dont update it and mess around with your pc for a couple of days.... convenient?

Rating: 7 out of 10 posted Wednesday, 26-Mar-08 at 19:51
Guido Ronconi a part-timer user from Argentina writes:
Hi. Saffire pro works with no problem at all in my PC (xp)system. I even used it as a standalone mixer and it does the job. It is true you have to check a lot of things in any system to make work fine. In xp, i.e. I've chosen to turn off all windows sound thinking the following: I'm working with 48000 hz or 96 khz sometimes and those sounds are not that rate. Imagine a sound card going from 96 to 12 just to make a sound of a mouse click. Those are no details. And a "Mac out of the box" is shure full of those. Focusrite is a pretty pro gear and asumes you go and think what you need to use. Anyways I now also think if those pieces really had trouble maybe you can sue Focusrute and that will solve all. Just be shure. PD: Those windows crappy sounds didn't mae any problems anyways.

Rating: 10 out of 10 posted Thursday, 28-Feb-08 at 16:26
page 1 of 4:   1   2   3   4    

Add your review
NEW SYSTEM - to keep the user reviews focussed, we are now approving all submissions before they appear.
We will endeavour to process your comments within 24hrs

Do not post items for sale or wanted here (they will be removed)
Use the Sonic Free Ads
Name
Email
Mail me Sonic State News
From:
(Country)
[ Professional Part TimeHobby-ist ] User
Nature of comments:
comment question
Whaddaya think: (blank lines are converted to paragraph breaks)
No HTML please.
Score 1=low 10=hi