WNAMM10: impOSCar 2 Video Demo

GForce ReleaseThe Beast!      16/01/10

No flash plug


   Windows Media 
6:2 mins

It's that man again. Cheeky chappy Dave Spiers with the lowdown on the eagerly awaited new version of their legendary virtual beast, the impOSCar.

 


All WNAMM 2010 News |  Videos |  Live Blogs |  Follow us on Twitter and Facebook
More From: GMEDIA
Even more news...

16 Comments...  Post a comment    original story
Niko    Said...

Methinks there is an error with this video, I cannot get it to load :(

I was really looking forward to this one too.

16-Jan-10 11:03 AM


Imposcarite    Said...

Ditto, the various commercial cues roll and then it halts at 'buffering'.

16-Jan-10 11:09 AM


geiger167    Said...

Yeah video don't work lol

16-Jan-10 11:14 AM


Matt_C    Said...

I'm glad it's not just me. I just re-installed Flash and checked for updates to Flip4Mac.

16-Jan-10 11:15 AM


Stuart    Said...

working now - great as always with the GForce stuff

16-Jan-10 11:21 AM


Imposcarite    Said...

Wonderful and every-thingevery-thing-everythingevery..

16-Jan-10 11:39 AM


mysticradio    Said...

Dave...... yoohoo Dave.... dave spiers ........ PLEASE put it out this year.......pretty please with sugar on top

16-Jan-10 12:16 PM


Marc JX8P    Said...

It's been my privilege to help test this thing and create some sounds for it. Absolutely gorgeous sound, fantastic flexibility and the new GUI and browser are fantastic to use! A big thanks to the GForce team for their commitment to quality and fun instruments!

16-Jan-10 12:17 PM


paul    Said...

great synth!

16-Jan-10 12:24 PM


tombomb    Said...

I've been waiting,from last year,and finally broke down 6 weeks before Christmas thinking no Company could miss that markect after a years hype, wrong, waiting teaches, fustration teaches ahhh

16-Jan-10 12:53 PM


Rob    Said...

REZ!!!!!!!!!!

16-Jan-10 07:08 PM


Stan    Said...

Video's in my case only working in Internet Explorer, not in Firefox.

17-Jan-10 05:20 AM


Bod    Said...

Yep, no vids working in Firefox...

17-Jan-10 01:00 PM


The Guvnor    Said...

I'm running Firefox 3.5.7 and vids are fine for me. Try upgrading to the latest version and see if that helps if you aren't already.

ImpOscar 2 sounds awesome. Put me down on the list for an upgrade!!!

BTW: Did Dave pay the extortionate fee for booth space this year or did he just set his laptop up outside the bar on a table and slip the security guards a $20 bill to get in the back door :0)

17-Jan-10 08:26 PM


Simon Power    Said...

Apologies for the initial glitchiness of this vid, guys. Should be AOK, now. enjoy!

18-Jan-10 06:29 AM


ehdyn    Said...

Dumb question: In the presets list it mentions one - Richard James. It's not AFX right?

18-Jan-10 04:16 PM


Post a comment 
 


More Videos

System-1 Review Part 2 Plug-Out And SH-101 Compared 

Out with the scope


Will Gregory's Moog Ensemble - Interview 

7 Monosynths play classical


Modular Review: STG Sound Labs .MIX Module 

3 channels with bi-polar output


Sonic LAB Review: Presonus StudioLive AI Desk 

32.4.2 AI